Перерасчет основных начислений

Основные настройки расчета зарплаты

Перерасчет основных начислений

Настройки по расчету зарплаты выполняются в разделе Настройка – Расчет зарплаты.

Для проверки настроек по расчету зарплаты их можно распечатать, нажав в самом верху настроек кнопку Настройки расчета зарплаты:

Расчет и выплата зарплаты по организации 

Флажок Расчет и выплата зарплаты выполняется по организации в целом определяет видимость поля Подразделение в шапках документов по начислению и выплате зарплаты.

Если флажок установлен, то поле Подразделение в шапках документов не отображается.

Если флажок не установлен, то поле Подразделение становится видимым:

Если в реквизите Подразделение:

  • указать конкретное подразделение — тогда заработная плата рассчитается только по выбранному подразделению;
  • не заполнять подразделение – тогда заработная плата рассчитается в целом по организации.

Флажок Расчет и выплата зарплаты выполняется по организации в целом можно снимать, а затем вновь устанавливать. Если флажок установить, то поле Подразделение перестанет быть видимым в шапках документов начислений и выплат, но уже введенная информация сохранится.

Автоматический пересчет документов при их редактировании 

При установленном флажке Выполнять автоматический пересчет документов при их редактировании производится автоматический расчет данных после заполнения документа или редактирования информации в нем.

Если данный флажок снять, то в этом случае в документах появляются две кнопки: Заполнить и Пересчитать.

В документе Начисление зарплаты и взносов эти кнопки выглядят следующим образом:

В других документах, например, в Отпуске (Зарплата – Отпуска – Отпуск) кнопка Пересчитать выглядит в виде двух стрелок и в случае необходимости пересчета подсвечивается красным цветом:

Учет по статьям финансирования 

Статья финансирования – дополнительный сквозной аналитический разрез учета. В разрезе статей финансирования в программе ведется учет начислений, удержаний и выплат.

Сведения для расчета общего среднего заработка принимать к учету для расчета пособий и наоборот 

Настройка Сведения для расчета общего среднего заработка принимать к учету для расчета пособий (и наоборот) срабатывает, если учет начали вести с нуля в 1С:ЗУП 3, и ввели данные для расчета среднего заработка вручную:

В этом случае в документе Отпуск следует на вкладке Основной отпуск нажать кнопку с зеленым карандашом для поля Средний заработок и внести вручную информацию в открывшуюся форму Ввод данных для расчета среднего заработка:

При проведении документа Отпуск введенные в эту форму данные будут зафиксированы как база среднего заработка для расчета больничных листов. И наоборот, если внести вручную данные для расчета среднего в документе Больничных лист, то эти данные автоматически попадут в базу для расчета общего среднего заработка.

Пересчет тарифных ставок 

Настройка При пересчете тарифной ставки сотрудника в стоимость часа (дня) использовать определяет, на что будет делиться Совокупная тарифная ставка (в частном случае — Оклад) при ее пересчете в стоимость часа (дня) для оплаты ночных, праздничных или сверхурочных часов (дней) работы:

Установленное значение — это значение по умолчанию, в кадровых документах (например, в Приеме на работу) для каждого конкретного сотрудника оно может быть переопределено.

Проверка соответствия начислений и выплат 

При установленном флажке Проверять соответствие начислений и выплат в программе осуществляется контроль за тем, чтобы не переплатить сотруднику.

В этом случае при попытке проведения документа будет выдано сообщение о невозможности провести документ из-за несоответствия начислений и выплат:

В этом случае документ Начисление зарплаты и взносов не проведется, и будет выдано предупреждение о том, что по сотруднице Ромашкиной Р.Р. уже произведена выплата, превышающая начисленное:

Выполнять доначисление и перерасчет отдельным документом 

В программе имеется механизм автоматического отслеживания и проведения перерасчетов. Сведения о том, какие документы по мнению программы необходимо пересчитать можно увидеть в разделе Зарплата – Сервис – Перерасчеты.

По умолчанию все накопленные, но не обработанные пользователем за месяц перерасчеты (кроме перерасчетов среднего заработка) программа автоматически обрабатывает при начислении зарплаты за очередной месяц.

Если в настройках расчета зарплаты установить флажок Выполнять доначисление и перерасчет зарплаты отдельным документом, то автоматическая обработка перерасчетов при начислении зарплаты производиться не будет. Предполагается, что в этом случае все необходимые перерасчеты пользователи будут проводить самостоятельно с помощью специализированного документа Доначисление, перерасчет.

Программа отследит действие по изменению размера оклада и предложит пересчитать заработную плату сотруднику за ноябрь 2017 г., отразив эту информацию в сервисе Перерасчеты:

Для перерасчета зарплаты сотрудника в этом случае можно воспользоваться одним из двух вариантов.

Вариант 1. Если не производить никаких действий с зафиксированным перерасчетом, то при начислении заработной платы за декабрь 2017 г.

в документе Начисление зарплаты и взносов перерасчет автоматически попадет на вкладку Доначисления, перерасчеты (отсторнируется все, что было начислено сотруднику, и будет произведено начисление исходя из новых условий)

Вариант 2.  Если требуется произвести перерасчет раньше начисления заработной платы за декабрь 2017 г., то можно открыть сервис Перерасчеты, выделить строку с сотрудником и нажать кнопку Доначислить сейчас:

Будет создан документ Доначисления, перерасчеты (Зарплата – Доначисления, перерасчеты), в котором автоматически будут произведены перерасчеты исходя из новых условий:

По просьбе организаций, в которых часто перепроводятся документы, и в учете которых часто фиксируется информация о необходимости перерасчетов или доначислений, фирма 1С реализовала возможность отключить автоматическое попадание доначислений и перерасчетов в документ Начисление зарплаты и взносов. Отключение производится установкой флажка Выполнять доначисление и перерасчет зарплаты отдельным документом в настройках расчета зарплаты.

В этом случае информация по перерасчетам все также будет фиксироваться механизмом Перерасчеты, но выполнить их можно будет только в документе Доначисления, перерасчеты.

Источник: http://buhpoisk.ru/osnovny-e-nastrojki-rascheta-zarplaty.html

Перерасчет основных начислений

Перерасчет основных начислений

Основными причинами перерасчета являются:

1) Ввод документа «задним числом» (документ, который не был своевременно принят к учету);

2) Исправление документа прошлого периода;

3) Сторнирование документа.

ВАЖНО: даже если в документе прошлого периода не было никаких изменений, но он был перепроведен, программа регистрирует перерасчет. Документ, из-за которого выполняется перерасчет, может быть любым: от кадрового (отпуск, больничный лист, командировка) до Начисления зарплаты.

Чтобы избежать или устранить перерасчеты, используются несколько методов:

1) Установка даты запрета изменения данных (доступно только под правами администратора). В разделе Администрирование выбираем пункт Даты запрета изменения данных.

Есть несколько вариантов установить дату запрета (например, для всех пользователей, или отдельно для каждого). Воспользуемся общим запретом.

При установке даты запрета документы, созданные до этой даты, станут недоступны для редактирования и перепроведения (панель неактивна):

2) В настройках расчета зарплаты укажем, что доначисления выполняются только по отдельному документу. Для этого переходим в меню Настройки, пункт Расчет зарплаты.

Внизу страницы отмечаем галочкой «Выполнять доначисление и перерасчет» отдельным документом.

Тогда в документе «Начисление зарплаты» не будет автоматических перерасчетов. Увидеть их можно только сформировав документ «Доначисления, перерасчеты» в меню Зарплата:

При этом в документе «Начисление зарплаты» останется напоминание о перерасчете, но сама вкладка перерасчетов будет пустой.

Существует 2 способа убрать напоминание:

a.) Выполнить доначисление (если не было причин для перерасчета, например, документ прошлого периода был проведен без изменений, или изменились не влияющие на расчет реквизиты, то фактически доначислений не будет либо будут нулевыми).

b.) Удалить перерасчет вручную. На вкладке Зарплата, в разделе Сервис находим Журнал перерасчетов.

В нем можно управлять перерасчетами и вручную отменить зарегистрированные программой перерасчеты, нажав правой кнопкой мыши и выбрав пункт Отменить (при условии, что они не повлияют на расчет и действительно лишние).

3) Также с помощью журнала Перерасчеты можно вручную вызвать перерасчет (если он по каким-то причинам не произвелся автоматически). Для этого по кнопке Добавить выбираем Перерасчет зарплаты или Перерасчет удержаний.

Форма заполнения простая: месяц регистрации, сотрудник, и документ, который является причиной перерасчета.

Консультант Компании «АНТ-ХИЛЛ»

При цитировании статей или заметок ссылка на сайт автора обязательна

Исправления и перерасчеты заработной платы

В программе «1С:Зарплата и управление персоналом 8» редакции 3.0 начиная с версии 3.0.

24* усовершенствован механизм исправления первичных документов, касающихся расчета и перерасчета заработной платы, а также пособий за прошлые периоды, удержанного из зарплаты НДФЛ и исчисленных страховых взносов. Об этом в статье расскажет А.Д.

Радченко, специалист компании ООО «1С-Корпоративные системы управления», являющейся центром компетенции по ERP-решениям фирмы «1С» (1С:Центр ERP), имеющей статус «1С:Центр сетевой компетенции», участника проекта «1С:Консалтинг».

В работе расчетчика достаточно часто встречаются ситуации, когда необходимо частично или полностью изменить данные ранее введенных документов, напрямую или косвенно участвующих в расчете зарплаты.

Ситуации могут быть связаны со счетными ошибками бухгалтера, кадровыми и организационными изменениями в компании, индексацией заработной платы, «опоздавшего» больничного.

Бывают и курьезные случаи, например, выплата двух зарплат сотруднику – за себя и за однофамильца. Нередко обнаруживаются ошибки и при проведении инвентаризации.

Законодательство о корректировке зарплаты – о чем важно помнить

При корректировке заработной платы как в сторону увеличения, так и уменьшения, нужно следовать нормам законодательства. Так, согласно Трудовому кодексу РФ перерасчет зарплаты производится, например, в случае индексации заработной платы (ст. 134 ТК РФ). Излишне начисленная зарплата может быть удержана (ст. 137 ТК РФ):

  • для возмещения неотработанного аванса, выданного работнику в счет заработной платы;
  • для погашения неизрасходованного и своевременно не возвращенного аванса;
  • для возврата сумм, излишне выплаченных работнику вследствие счетных ошибок, а также сумм, излишне выплаченных работнику, в случае признания органом по рассмотрению индивидуальных трудовых споров вины работника в невыполнении норм труда;
  • при увольнении работника до окончания того рабочего года, в счет которого он уже получил ежегодный оплачиваемый отпуск, за неотработанные дни отпуска.

Обратите внимание, что излишне выплаченую зарплату, в том числе при неправильном применении норм трудового законодательства, нельзя удержать, за исключением:

  • счетной ошибки**;
  • если органом по рассмотрению индивидуальных трудовых споров признана вина работника в невыполнении норм труда или простое;
  • если заработная плата была излишне выплачена работнику в связи с его неправомерными действиями, установленными судом.

В других случаях работник может возместить ошибочно выданную зарплату только в добровольном порядке (п. 3 ст. 1109 ГК РФ).

ИС 1С:ИТС

Об удержаниях из заработной платы сотрудника по инициативе работодателя; по исполнительным листам; по инициативе работника читайте в « Справочнике кадровика» в разделе «Кадры и оплата труда».

Новые возможности «1С:Зарплаты и управления персоналом 8» по исправлению зарплаты

Механизм исправления первичных учетных документов и перерасчета заработной платы давно существует в типовых продуктах «1С:Предприятия», автоматизирующих расчет зарплаты: «1С:Зарплата и кадры 7.

7», «1С:Зарплата и управление персоналом 8» (ред. 2.5) и других программах, включающих в себя компоненты расчета заработной платы. В программе «1С:Зарплата и управление персоналом 8» (ред. 3.

0) этот механизм усовершенствован и сделан более удобным для пользователя.

Исправить документы, и принять исправления к учету можно тремя способами:

  • ввести документ «задним числом» — это, например, «забытый документ», который не был своевременно принят к учету;
  • исправить документ прошлого периода;
  • сторнировать документ.

Рассмотрим, как отражать каждую из этих ситуаций в программе «1С:Зарплата и управление персоналом 8» редакции 3.0.

Ввод документа «задним числом» — «забытый документ»

Данный способ позволяет зарегистрировать в базе документ, относящийся к прошедшему периоду.

Создадим документ Больничный лист с месяцем регистрации Февраль 2015. Период больничного листа укажем — с 16 по 31 января (рис. 1).

Суммарные значения начислений и отдельно суммарные значения выполненных перерасчетов отражаются на первой странице документа. Это позволяет пользователю визуально контролировать результаты расчета. Перерасчеты начислений прошлых периодов отделены от начислений и отражаются на отдельной закладке документа Перерасчет прошлого периода.

Исправление документа прошлого периода

Данный способ используется, если в текущем периоде производится корректировка информации, содержащейся в документе, принятом к учету в прошлом периоде.

Источник: https://nnvrsk.ru/pereraschet-osnovnyh-nachislenij

Перерасчет выбранных в списке документов

Перерасчет основных начислений

Часто при внедрении 1С:ЗУП на больших проектах внутри холдинга возникает задача реализовать групповой перерасчет документов «Начисление зарплаты». Заказчики хотят иметь возможность выделять сразу несколько документов в списке и их пересчитывать нажатием на одну кнопку. Типовой ЗУП не дает возможности перерасчитывать документы прямо в списке.  

1. Групповой перерасчет выбранных в списке документов «Начисление зарплаты и Взносов» в ЗУП 3.1.2

Заказчик хочет следующий функционал:

Решение.

В конфигураторе создаем новую форму списка документа копированием типовой. Задаем префикс в имени формы. Создаем команду формы списка, подменю «ГруппаПересчетДокументов». Устанавливаем флаг «Множественный выбор» в свойствах элемента формы «Список» — чтобы пользователи могли выделять несколько документов при нажатии «Ctrl+Клик мыши».

Спустя некоторое время добавил еще одну кнопку:

Кнопка «Пересчитать (аналог: над таблицей Начисления)» — работает так же, как если бы мы открыли документ и нажали в нем кнопку Пересчитать над табличной частью Начисления (справа от кнопки Очистить), пересчет может потребоваться когда мы вручную меняем Результат начисления по сотруднику и надо по цепочке далее пересчитать зависимые начисления, налоги и взносы. 

Кнопка «Пересчитать (аналог: таблица Начисления Сtrl+A —> прав. кнопка мыши Пересчитать сотрудника)»  —  работает так же, как если бы мы открыли документ, выделили все строки в таблице Начисления (Сtrl+A) и нажали правой кнопкой мыши Пересчитать сотрудника.

В этом случае происходит не только пересчет сотрудника, но перезаполнение всех начислений сотрудника (как при первичном нажатии на кнопку Подбор). Это может понадобиться, когда сотрудник в документ есть, но в документе не хватает каких-либо начислений по нему (их ввели немного позже, после первого заполнения документа).

Можно не заходя внутрь документа сделать дозаполнение недостающих начислений и сразу перерасчет. 

В модуле созданной формы списка пропишем текст процедуры «ПересчитатьСотрудниковВДокументах»

 Листинг нетипового функционала модуля формы списка ЗУП 3.1.2 #Область Нетиповая &НаКлиенте //Кнопка 1 Процедура ПересчитатьСотрудниковВДокументах(Команда) //Предупредить пользователя о том, чтобы по выбранным документам не было открытых форм. Формы открыты: Да/Нет. МассивВыделенныхДокументов = Элементы.Список.ВыделенныеСтроки; Для Каждого ЭлМасДок из МассивВыделенныхДокументов Цикл ФормаДокумента = ПолучитьФорму(«Документ.НачислениеЗарплаты.Форма.ФормаДокумента», Новый Структура(«Ключ»,ЭлМасДок), ЭтаФорма); ИмяТаблицы = «Начисления»; ВедущееПоле = «Сотрудник»; ТипВедущегоПоля = Тип(«СправочникСсылка.Сотрудники»); //—————————————————————————————————————————————— //1. ФормаДокумента.СотрудникиКРасчету = СоответствиеСотрудникиКРасчету(ФормаДокумента, ИмяТаблицы); ФормаДокумента.ПересчитатьДокументНаКлиенте(); //—————————————————————————————————————————————— //2. ФормаДокумента.Записать(); //—————————————————————————————————————————————— //3. Закроем окно длительной операции ОкнаПриложения = ПолучитьОкна(); Для Каждого ОкноПриложения Из ОкнаПриложения Цикл Если ОкноПриложения.Содержимое.Количество()=0 Тогда Продолжить; КонецЕсли; Если ОкноПриложения.Содержимое[0].ИмяФормы=»ОбщаяФорма.ДлительнаяОперация» и НЕ ОкноПриложения.НачальнаяСтраница и НЕ ОкноПриложения.Основное Тогда ФормаДлОп = ОкноПриложения.ПолучитьСодержимое(); Если ФормаДлОп.Открыта() Тогда ФормаДлОп.Закрыть(); КонецЕсли; КонецЕсли; КонецЦикла; КонецЦикла; Элементы.Список.Обновить(); ЭтаФорма.ОбновитьОтображениеДанных(); КонецПроцедуры &НаКлиенте Функция СоответствиеСотрудникиКРасчету(ФормаДокумента, ИмяТаблицы) ОписаниеТаблицы = РасчетЗарплатыРасширенныйКлиентСервер.ОписаниеТаблицыРасчета(); ОписаниеТаблицы.ИмяПоляДляВставкиПоказателей = «ДатыНачисления»; ОписаниеТаблицы.СодержитПолеСотрудник = Истина; ОписаниеТаблицы.ИмяРеквизитаСотрудник = «Сотрудник»; ОписаниеТаблицы.ИмяПоляДляВставкиРаспределенияРезультатов = «НачисленияРезультат»; ОписаниеТаблицы.ОтображатьПоляОписанияВремени = Истина; ОписаниеТаблицы.ОтображатьПоляНормыВремени = Ложь; //Истина ОписаниеТаблицы.УправлятьОтображениемПолейОписанияВремени = Ложь; //Истина ОписаниеТаблицы.ОтменятьВсеИсправления = Ложь; ОписаниеТаблицы.ПутьКДаннымАдресРаспределенияРезультатовВХранилище = «АдресТаблицыРаспределенияНачислений»; ОписаниеТаблицы.ВставлятьПослеПоля = Истина; ОписаниеТаблицы.РаспределениеРезультатовЗависимыеТаблицы = «Начисления,Пособия,НДФЛ,Удержания,ПогашениеЗаймов»; ОписаниеТаблицы.СодержитПолеКодВычета = Истина; ОписаниеТаблицы.ИмяРеквизитаДокументОснование = «ДокументОснование»; ОписаниеТаблицы.ПутьКДаннымАдресРаспределенияПоТерриториямУсловиямТруда = «АдресТаблицыРаспределенияПоТерриториямУсловиямТруда»; ОписаниеТаблицы.Вставить(«НачисленияРезультат»,»»); СписокСотрудников = Новый Соответствие; Для Каждого ТекСтр Из ФормаДокумента.Объект[ИмяТаблицы] Цикл ФЛ = ТекСтр.ФизическоеЛицо; Если СписокСотрудников.Получить(ФЛ) = Неопределено Тогда СписокСотрудников.Вставить(ФЛ,Истина); КонецЕсли; КонецЦикла; СтруктураНачисления = Новый Структура(«ОписаниеТаблицы,СписокСотрудников»); СтруктураНачисления.ОписаниеТаблицы = ОписаниеТаблицы; СтруктураНачисления.СписокСотрудников = СписокСотрудников; СотрудникиКРасчету = Новый Соответствие(); СотрудникиКРасчету.Вставить(«Начисления», СтруктураНачисления); Возврат СотрудникиКРасчету; КонецФункции &НаКлиенте //Кнопка 2 Процедура ПерезаполнитьИПересчитатьСотрудника(Команда) //Предупредить пользователя о том, чтобы по выбранным документам не было открытых форм. Формы открыты: Да/Нет. МассивВыделенныхДокументов = Элементы.Список.ВыделенныеСтроки; Для Каждого ЭлМасДок из МассивВыделенныхДокументов Цикл ФормаДокумента = ПолучитьФорму(«Документ.НачислениеЗарплаты.Форма.ФормаДокумента», Новый Структура(«Ключ»,ЭлМасДок), ЭтаФорма); ИмяТаблицы = «Начисления»; ВедущееПоле = «Сотрудник»; ТипВедущегоПоля = Тип(«СправочникСсылка.Сотрудники»); //—————————————————————————————————————————————— //1. Для каждого Стр Из ФормаДокумента.Объект.Начисления Цикл ФормаДокумента.Элементы.Начисления.ВыделенныеСтроки.Добавить(Стр.НомерСтроки-1); КонецЦикла; ИдентификаторыСтрок = ФормаДокумента.Элементы[ИмяТаблицы].ВыделенныеСтроки; //РасчетЗарплатыРасширенныйКлиент.ПересчитатьСотрудника(ФормаДокумента, «Начисления», «Сотрудник», Тип(«СправочникСсылка.Сотрудники»)); ФормаДокумента.ПересчитатьСотрудника(ИмяТаблицы, ИдентификаторыСтрок, ВедущееПоле, ТипВедущегоПоля); //—————————————————————————————————————————————— //2. ФормаДокумента.Записать(); //—————————————————————————————————————————————— //3. Закроем окно длительной операции ОкнаПриложения = ПолучитьОкна(); Для Каждого ОкноПриложения Из ОкнаПриложения Цикл Если ОкноПриложения.Содержимое.Количество()=0 Тогда Продолжить; КонецЕсли; Если ОкноПриложения.Содержимое[0].ИмяФормы=»ОбщаяФорма.ДлительнаяОперация» и НЕ ОкноПриложения.НачальнаяСтраница и НЕ ОкноПриложения.Основное Тогда ФормаДлОп = ОкноПриложения.ПолучитьСодержимое(); Если ФормаДлОп.Открыта() Тогда ФормаДлОп.Закрыть(); КонецЕсли; КонецЕсли; КонецЦикла; КонецЦикла; Элементы.Список.Обновить(); ЭтаФорма.ОбновитьОтображениеДанных(); КонецПроцедуры #КонецОбласти

Пример работы реализованного функционала в пользовательском режиме 1С:Предприятие:

Перерасчет выбранных документов работает так же, как и кнопки внутри документа «Пересчитать» или «Пересчитать сотрудника» (если все сотрудники выбраны):

Подводные камни:

1) перед началом перерасчета выделенных документов желательно организовать проверку не открыта ли какая либо из форм одного из выбранных документов сейчас, если открыта — выдавать предупреждение о том, что надо ее закрыть (этого в коде выше нет)

2) в процессе перерасчета начинают отображаться формы длительной операции — нужно позаботиться о закрытии этих форм после перерасчета (в коде выше это есть)

3) после перерасчета выбранных документов иногда приходится обновить список документов вручную, поскольку некоторые документы начинают отображаться как не проведенные, хотя в коде и присутствует строчка

Элементы.Список.Обновить();

4) массовый перерасчет документов может вызывать конфликт блокировок при выполнении транзакции по причине превышении времени ожидания запроса на блокировку.

5) рекомендую изучить механизм утверждения (и расчета) межрасчетных документов в журнале «Начисление зарплаты»: когда кадровики вводят документы, затем расчетчики должны эти документы выделить, утвердить и рассчитать. Механизм работы кнопки «Утвердить» содержит типовые алгоритмы перебора выделенных документов и их расчета — очень рекомендую их изучить.  

2. Групповой перерасчет выбранных в списке документов «Начисление зарплаты сотрудникам организаций» в ЗУП 2.5.123

Заказчик хочет следующий функционал:

Решение.

В конфигураторе создаем новую форму списка документа копированием типовой. В элемент формы «ДокументСписок» добавляем колонку «Пометка» (без привязки к данным базы данных). Для элемента формы «ДокументСписок» добавляем командную панель с тремя подменю, см. рисунок.

Реализация выделения документов в списке.

Создаем реквизит формы «ТаблицаПометок».

Создаем 3 процедуры для выделения документов в списке:

ДокументСписокПриПолученииДанных(…),ДокументСписокВыбор(…),КоманднаяПанель1СнятьФлажки(…)

Листинг процедур для выделения документов в списке (ЗУП 2.5.123): Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок) Если ТаблицаПометок.Количество()=0 Тогда Возврат; КонецЕсли; Для Каждого СтрокаТЧ Из ОформленияСтрок Цикл ДанныеСтроки = СтрокаТЧ.ДанныеСтроки; Ячейки = СтрокаТЧ.Ячейки; ЭлТаб = ТаблицаПометок.Найти(ДанныеСтроки.Ссылка,»Ссылка»); Если ЭлТаб=Неопределено Тогда Продолжить; КонецЕсли; Ячейки.Пометка.УстановитьКартинку( ?(ЭлТаб.Пометка, БиблиотекаКартинок.Утвердить, Новый Картинка) ); СтрокаТЧ.Шрифт = Новый Шрифт (,,ЭлТаб.Пометка); КонецЦикла; КонецПроцедуры Процедура КоманднаяПанель1СнятьФлажки(Кнопка) Для Каждого ТекСтр Из ТаблицаПометок Цикл ТекСтр.Пометка = Ложь; КонецЦикла; ЭлементыФормы.ДокументСписок.ОбновитьСтроки(); КонецПроцедуры Процедура ДокументСписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка) Если Колонка.Имя=»Пометка» Тогда СтандартнаяОбработка=Ложь; ЭлТаб = ТаблицаПометок.Найти(Элемент.ТекущиеДанные.Ссылка,»Ссылка»); Если ЭлТаб=Неопределено Тогда НовСтр = ТаблицаПометок.Добавить(); НовСтр.Ссылка = Элемент.ТекущиеДанные.Ссылка; НовСтр.Пометка = Истина; Иначе ЭлТаб.Пометка = НЕ ЭлТаб.Пометка; КонецЕсли; КонецЕсли; ЭлементыФормы.ДокументСписок.ОбновитьСтроки(); КонецПроцедуры

Реализация перерасчетов выделенных документов в списке.

Для каждой кнопки подменю добавленной командной панели элемента формы «ДокументСписок» создаем свой обработчик и одну общую процедуру ОбработатьДокументы(ВариантДействий) для всех вариантов перерасчета выбранных документов.

В ЗУП 2.5 в обычных формах мы можем очень просто реализовать расчет в форме списка:

Объект.РассчитатьВсе(); или Объект.РассчитатьНачисления(); или Объект.РассчитатьНДФЛ();

 Листинг процедур перерасчета выделенных документов (ЗУП 2.5.123)

Источник: https://infostart.ru/public/807219/

Практикум 11. План видов расчета, регистр расчета

Перерасчет основных начислений

Курсы Стимул › Справочник › Полезные материалы › 1С:Предприятие 8.2 › Разработчикам › Практикум

1С:Предприятие 8.2 /
Разработчикам /
Практикум

Оглавление

Объект конфигурации План видов расчета

Создание плана видов расчета ОсновныеНачисления

Создание регистра расчета Начисления

Использование регистра расчета. Создание документа НачисленияСотрудникам

Познакомимся с объектами конфигурацииПлан видов расчета и Регистр расчета и узнаем об основных понятиях, используемых при создании сложных периодических расчетов.

Такие расчеты используются, прежде всего, при расчете заработной платы . Поэтому дальнейшее их рассмотрение мы будем строить на примере расчета заработной платы сотрудников, которые работают в нашей фирме.

В общем случае сумма заработной платы сотрудника складывается из множества частей. Например, оплата по окладу, премия, штрафы, оплаты по больничному листу, разовые выплаты и т.д. Каждая из этих частей рассчитывается по некоторому алгоритму, присущему только этой части.

Например, сумма штрафа может определяться просто фиксированной суммой , сумма премии может рассчитываться как процент от оклада, а сумма оплаты по окладу рассчитывается исходя из количества рабочих дней в месяце и количества дней , отработанных сотрудником.

Поэтому для обозначения каждой такой части мы будем использовать термин вид расчета.

Алгоритм каждого вида расчета опирается в общем случае на две категории параметров: период, за который нужно получить конечные данные, и набор некоторых исходных данных, используемых при расчете.

Как правило, в реальной жизни различные виды расчета существуют не сами по себе, а оказывают некоторое влияние на другие виды расчета. Исходя из того, что вид расчета опирается на две различные категории параметров, такое влияние тоже имеет двойственный характер.

Во-первых, это может быть влияние на исходные данные, используемые при расчете. В качестве примера можно привести начисление премии в виде процента от оплаты по окладу. При изменении оплаты по окладу размер премии тоже должен быть пересчитан, исходя из новой суммы начисленного оклада.

Другими словами, сумма начисленного оклада является базой для расчета премии. Причем, поскольку оклад рассчитывается за некоторый период, при расчете премии нам интересно знать не значение оклада вообще, а сумму, начисленную в том периоде, который влияет на расчет премии.

Такой период мы будем называть базовым, а подобную зависимость между видами расчета → зависимостью по базовому периоду.

В качестве примера рассмотрим начисление премии за апрель. Премия должна начисляться в размере 10% от суммы, начисленной в качестве оплаты по окладу.

Следовательно, необходимо проанализировать все записи о начислениях оплаты по окладу, которые попадают в интересующий нас базовый период, а именно апрель.

Допустим, общая сумма таких начислений составила 8 000 рублей → в этом случае премия должна быть начислена в размере 800 рублей.

Во-вторых, это влияние может быть не на исходные данные, а на сам период, за который производится расчет. В качестве примера можно привести расчет оплаты по окладу и невыход на работу. Предположим, мы начислили сотруднику оплату по окладу за март месяц. В этом случае период действия такого расчета будет с 1 марта по 31 марта.

После этого мы получили информацию от руководителя отдела, что, оказывается, сотрудник отсутствовал на работе с 1 по 10 марта по неизвестной причине. В этом случае нам нужно будет произвести расчет Невыход, в котором можно рассчитать какие-то удержания с сотрудника.

Но кроме этого необходимо будет пересчитать и оклад сотрудника, исходя из того, что фактический период действия расчета Оклад стал теперь с 11 марта по 31 марта. Такое влияние мы будем называть вытеснением по периоду действия.

В результате если за полный месяц работы сотруднику должно было быть начислено 9 300 рублей, то теперь, за фактический период работы, начисление составит 6 300 рублей.

Таким образом, исходя из двух видов взаимного влияния расчетов, можно сказать, что в общем случае с каждым видом расчета будет связано три периода:

  • период действия;
  • фактический период;
  • базовый период.

Период действия является «запрашиваемым». То есть, указывая период действия, мы говорим, «Мы хотели бы, чтобы результат действовал в этом периоде».

Фактический период → это то, что получилось из периода действия после анализа всех периодов действия расчетов, которые вытесняют наш по периоду действия.

Базовый период → это период, в котором мы анализируем результаты других расчетов, влияющих на наш по базовому периоду.

Как видите, взаимное влияние между видами расчетов может быть довольно разнообразным и, что самое сложное, многоуровневым. То есть один вид расчета может влиять на другой, который, в свою очередь, влияет на третий, и т.д.

Очевидно, что в такой ситуации требуется некий универсальный механизм, позволяющий описать каждый из видов расчетов (его алгоритм, влияние на другие виды расчетов , зависимость от других видов расчетов), обеспечить хранение данных, полученных в результате этих расчетов, и контроль необходимости перерасчета результатов зависимых расчетов в случае изменения результатов «первичных» расчетов.

В системе 1С:Предприятие такой универсальный механизм реализован при помощи планов видов расчета и регистров расчета.

Объект конфигурации План видов расчета

Объект конфигурации План видов расчета является прикладным и предназначен для описания структуры хранения информации о возможных видах расчетов.

На основе объекта конфигурацииПлан видов расчета платформа создает в базе данных информационную структуру, в которой может храниться информация о том, какие существуют виды расчета и каковы взаимосвязи между ними.

Отличительной особенностью плана видов расчета является то, что пользователь в процессе работы может добавлять новые виды расчета. Такая возможность делает механизм периодических расчетов более гибким и позволяет пользователю создавать собственные виды расчета, помимо тех, которые заданы разработчиком как предопределенные.

Объект конфигурации План видов расчета имеет свойство Использует период действия. С его помощью определяется, будут ли в этом плане находиться виды расчета, которые могут быть вытеснены по периоду действия. Если это свойство установлено, то разработчик получает возможность указать для каждого вида расчета те виды, которые вытесняют его по периоду действия.

Следующим важным свойством объекта конфигурации План видов расчета является Зависимость от базы.

Оно определяет, будут ли в этом плане находиться зависимые по базовому периоду виды расчета.

Если это свойство установлено, появляется возможность указать, в каком плане видов расчета будут находиться базовые виды расчета и, кроме этого, как будет определяться эта зависимость.

Существует возможность указать один из двух видов зависимости от базы:

  • Зависимость по периоду действия;
  • Зависимость по периоду регистрации.

Еще одной важной особенностью плана видов расчета является возможность создания предопределенных видов расчета и описания их взаимного влияния. При этом в общем случае разработчик имеет возможность указать три категории видов расчета, влияющих на предопределенный вид расчета:

  • Базовые → их результаты должны быть использованы при перерасчете этого вида расчета;
  • Вытесняющие → вытесняют этот вид расчета по периоду действия;
  • Ведущие → изменение их результатов должно приводить к необходимости перерасчета этого вида расчета.

Здравый смысл подсказывает, что все базовые виды расчета должны быть включены и в категорию ведущих. Кроме того, ведущие виды расчета могут содержать и некоторые другие виды, косвенно влияющие на данный вид расчета.

Невыход вытесняет оклад по периоду действия, а премия зависит от оклада по базовому периоду. В этом случае для премии следует указать базовым видом расчета оклад, а ведущим → оклад и невыход, поскольку изменение результата расчета невыхода приведет к изменению результата оклада, что, в свою очередь, должно привести к изменению результата премии.

Создание плана видов расчета ОсновныеНачисления

1. Создадим новый объект конфигурации План видов расчета. Зададим ему имя → ОсновныеНачисления.

2. Перейдем на закладку Расчет и укажем, что он будет использовать период действия и зависеть от базы по периоду действия.

В качестве базового плана видов расчета укажем его самого, поскольку все наши виды расчетов будут храниться в единственном плане видов расчета.

3. Перейдем на закладку Прочее и зададим предопределенные виды расчета. Как и в случае с бухгалтерией, расчеты в нашей фирме будут «скромные», поэтому мы создадим всего три элемента:

  • Невыход → с именем и наименованием Невыход и кодом Невыход;
  • Оклад — с именем, кодом и наименованием Оклад и вытесняющим его видом расчета Невыход;
  • Премия — с именем, кодом и наименованием Премия, с базовым видом расчета Оклад и ведущими видами расчета Невыход и Оклад.

Объект конфигурации Регистр расчета

Объект конфигурации Регистр расчета является прикладным и предназначен для описания структуры накопления данных, являющихся результатами расчетов.

Отличительной особенностью регистра расчета является то, что он не предназначен для интерактивного редактирования пользователем.

Разработчик может при необходимости предоставить пользователю возможность редактировать регистр расчета, но предназначение этого регистра заключается в том, чтобы его модификация производилась на основе алгоритмов работы объектов базы данных, а не в результате непосредственных действий пользователя.

Как и другие регистры, регистр расчета имеет ресурсы, в которых хранит числовые данные; имеет измерения, в разрезе которых можно получать значения ресурсов регистра; имеет реквизиты, которые характеризуют каждую запись регистра расчета.

Особенностью же регистра расчета является его периодичность , возможность использования механизмов вытеснения по периоду действия и зависимости по базовому периоду, а также связь с планом видов расчета.

Периодичность регистра расчета может быть определена одним из следующих значений:

Периодичность регистра расчета определяет промежуток времени, к которому будет относиться каждая запись регистра.

Для указания факта принадлежности записи к какому-либо периоду регистр имеет служебный реквизит ПериодРегистрации типа Дата.

При записи данных в регистр платформа всегда приводит значение этого реквизита к началу того периода, в который он попадает.

Например, если в регистр расчета с периодичностью месяц записать данные, где ПериодРегистрации задан как 08.04.2008, то регистр сохранит эти данные со значением поля ПериодРегистрации

Источник: https://stimul.kiev.ua/materialy.htm?a=praktikum_11_plan_vidov_rascheta_registr_rascheta

Порядок работы с документом

Перерасчет основных начислений
19.10.2015 09:30 Administrator 16651

Регулярно, из месяца в месяц, бухгалтер сталкивается с начислением зарплаты. Конкретно к документу «Начисление зарплаты и взносов» в программе 1С: Зарплата и управление персоналом 8 редакции 3.

0 обращаются уже после того, как введены все документы-отклонения, документы по оплате праздничных и выходных дней, когда заполнены табели учета рабочего времени. Эта статья о том, как работать именно с данным основным документом начисления.

 

Для расчета оплаты переходим в раздел «Зарплата» и выбираем «Начисление зарплаты и взносов».                   

Чтобы произвести основные начисления сотрудникам в открывшемся окне нажимаем «Создать».

Появляется новый документ «Начисление зарплаты и взносов», который отличается от документа «Начисление зарплаты» редакции 2.5 количеством вкладок.                                                                                                  

Для автоматического заполнения табличного поля нажимаем «Заполнить».

После автоматического заполнения в начислениях можно заметить оплату по окладу и сверхурочные, доплату за работу в ночные часы и праздничные дни. На закладке «Начисления» можно выбрать сотрудника и воспользоваться кнопкой «Расчетный листок», в этом случае в отдельном окне будет сформирован расчетный лист по конкретному человеку.                                                           

Также на закладках с начислениями и удержаниями обращаем внимание на кнопку «Показать подробности расчета».                 

Благодаря ей, получаем развернутую таблицу с данными, из которых сложился результат начислений, либо удержаний.                               

Рассмотрим подробнее, какие еще начисления отражаются данным документом. Итак, вторая вкладка документа содержит информацию о перерасчетах.

Что это такое? Дело в том, что в программе автоматизирована возможность перерасчета и доначисления зарплаты при изменении данных, которые на нее влияют.

Например, сотрудников на самом деле приняли на работу, но не зарегистрировали это в программе и не начислили зарплату, то есть появилась потребность доначислить зарплату.

Как только информация о приеме на работу будет внесена, появится необходимость доначислить им зарплату в месяц приема на работу. Эту информацию можно увидеть в документе начисления зарплаты.                 

При условии, что данной возможностью не воспользовались, доначисление автоматически будет произведено при очередном плановом начислении зарплаты за следующей месяц на отдельной вкладке документа «Доначисления, перерасчеты».

Помимо трудовых отношений, которые регулируются ТК РФ, организация может вступать с физическими лицами в отношения, регулируемые Гражданским Кодексом Российской Федерации.

Например, договор подряда, в соответствии со статьей 702 ГК РФ, где одна сторона (подрядчик) обязуется выполнить по заданию другой стороны (заказчика) определенную работу и сдать ее результат заказчику, а заказчик обязуется принять результат работы и оплатить его.

Начисление и расчет вознаграждения по договору подряда, а также НДФЛ и страховых взносов с этих сумм также выполняется с помощью документа «Начисление зарплаты и взносов», смотрим расчеты на соответствующей вкладке.                             

На вкладке «Пособия» при автоматическом заполнении появляются строки по всем видам пособий, назначенных сотрудникам в плановом порядке.

Такие удержания, как профсоюзные взносы или удержания по исполнительным документам отражаются, соответственно, на вкладке «Удержания».                                                                                                         

Что касается расчета суммы налога с доходов в виде оплаты труда, то он также осуществляется рассматриваемым документом. Сумма исчисленного налога показывается на вкладке «НДФЛ».                                             

Слева в табличной части отражаются сотрудники, по которым исчислен НДФЛ, сумма налога, месяц начисления и подразделение, где числится сотрудник.

Справа в табличной части раздела указываются коды вычетов на детей, имущественных, личных вычетов и вычетов, предусмотренных для отдельных видов доходов, облагаемых НДФЛ частично, а также суммы и описание вычетов, которые предоставляются выделенному в списке сотруднику.

Таким образом, мы имеем возможность параллельно проверить внесена ли информация о праве сотрудника на вычеты. Ниже по гиперссылке открывается печатная форма регистра налогового учета по НДФЛ.                                                                                       

На вкладке «Займы» можно увидеть расчет суммы материальной выгоды, отраженный одновременно с расчетом сумм к удержанию в счет погашения займа и процентов за пользование заемными средствами.                         

В отличие от программы «1С: Зарплата и управление персоналом 8» редакции 2.5, в новой редакции нет отдельного документа для расчета взносов. Расчет базы для начисления страховых взносов и начисление страховых взносов производятся в одном документе.

Суммы начисленных обязательных ежемесячных платежей, подлежащие перечислению в ПФР, ФСС РФ и ФФОМС, отображаются на вкладке «Взносы». На которой есть возможность посмотреть подробнее карточку учета по страховым взносам, обратившись к одноименной гиперссылке внизу табличной части.

                                    

Таким образом выглядит работа с документом «Начисление зарплаты и взносов», который, как смогли убедиться, выполняет очень много важных расчетов.

Кристина Саввина 

Источник: https://xn--80abbnbma2d3ahb2c.xn--p1ai/mobile-rasch-zp/main/raschet-zarabotnoj-platy/poriadok-raboty-s-dokumentom-nachislenie-zarplaty-i-vznosov-v-1s-zarplata-i-upravlenie-personalom-8-redaktcii-3-0

Адвокат 24